Supermetrics Support Forum

System Error on Ad Data + Google Analytics Connector when applying filters.

Hi guys, I'm recently having this System Error on my reports on Data Studio using the Ad Data + Google Analytics connector when I apply a FILTER which is not being shown on the table, graphic or scorecard. 

For example, when I select a scorecard to show clicks and apply a filter by Campaign, it returns the error below. 


Data Studio has encountered a system error.

The number of columns received in the data returned from the community connector does not match the number of columns requested by Data Studio. Please report the issue to the provider of this community connector if this issue persists.

Error ID: 86ff967e


It's happening in all data sources I have using this connector. Does anyone have any idea on how to fix it? 


thanks so much!


  • Hi Rodrigo,

    Sorry, our spam filter caught this one on accident!

    This is a known issue and at the end of last week a fix was deployed that did correct this for some types of filters. However there are still some other filters where this is problem and our engineering team is working actively on those to fix them.

    Please refresh the connector and check if the first fix cleared the issue for you:
    How do I Refresh Fields/Update a Connector?

    If that does not work for all cases, then please let us know so we can make sure you get the notification about the next fix.

    ​-Thank you
    Supermetrics Team
Login to post a comment