Supermetrics Support Forum

Solved

Facebook taking FOOOOOREVER to load in DataSTudio

This is ridiculous!  It's taking a very long time to load.  Even with simple metrics and no filters.  Not acceptable when paying for the connector.  Over the past few months, the Facebook connector latency seems to bounce around from acceptable speeds (under 1 minute load time) to 3-5, and even 10+minutes.

PLEASE FIX!

  • Hi Laurean,

    My sincere apologies for the inconveniences that load times has caused to you.

    We are aware that there has been some issues in the Facebook connection lately, which is partly on Supermetrics side, and partly Facebook. For example yesterday, we did have some server issues causing slowness for a moment and consequently later in the evening there was also a problem on Facebook side, causing slow load times or errors. All of that should be ok now though. 

    We have a team focusing on query load times right now, and I trust they will be able to secure the performance to a high level.

    Again, apologies for the frustrating slowness you've encountered.

    If there's anything else we can help you with, please let us know.

    Best regards,
    Heidi / Supermetrics team
  • Is this still an ongoing issue? I signed up for a Facebook -> Data Studio connector last week and the report I built is essentially unusable because it takes soooo long to load when first visiting the report or any time a change is made to filters or date range. 

  • Hi Aaron,


    No, there are no ongoing issues with Facebook loading anymore.


    Usual causes to slow load times are:

    • multi account fetching
    • long date range
    • filters
    • granular dimensions involved in the query


    If none of those apply to your scenario, please reach out to us through a private ticket. Thanks!


    Best,

    Heidi / Supermetrics

Login to post a comment