Supermetrics Support Forum

Solved

Error in GA queries: "Processing is taking a lot of time at the moment. Please try again in a moment."

Hi,


The previous week several GA Core API queries (scheduled via Supermetrics) failed with the following query: 


"Error: Processing is taking a lot of time at the moment. Please try again in a moment."


I'm running queries for > 1 year now via Supermetrics without many problems and the query settings are not changed, so I don't have an obvious cause currently. Also, GA doesn't have to process significantly more hits in the specific account.


Are more people experiencing this issue? Does anyone know the cause and how to fix it?


Thanks in advance,

Timo Rietveld


6 people have this problem
  • I'm seeing the exact same error message; Error in GA queries: "Processing is taking a lot of time at the moment. Please try again in a moment."


    Performance on my GA queries has been getting progressively slower over the past 3 months or so, to the point where I've reduced the amount of data I'm pulling back to only 3 days, but it's now getting to the point where Supermetrics is not running any queries at all now and either giving me the above error message, or simply 'Google has reported too many 503 errors'.


    I'm not runing massviely complex queries either, simply sessions split by date and medium! I can't even get that to run successfully.


    Unfortunately Supermetrics' performance has been very unreliable for a long time now, particularly on the first of each month, to the point where we're going to have to find an alternative provider, as I'm litersally reduced to running custom reports manually in GA now.


    Thanks,

    Rob

  • Hi there, same error!

  • Same here

  • Same problem. And after manual (Sidebar refresh) query refresh all working fine. 

  • Yes same error, except mine hangs on 10%

  • What I'd like to mention as well (maybe it's related to this issue, not sure): if a query succeeds, the query execution time is really long the last weeks. For quite simple queries, the query time could be 15 minutes per query. (Reference for Supermetrics: See for example these query IDs: FYOGiKPLtY7Tuz8AGIviq9q5apLDSY (last run 815 seconds as seen from the SuperMetricsQueries sheet) and povKxucbRijeLxNLXCUf6cUd8o4FH1 (last run 584 seconds).) I didn't use a filter or segment here, so just a simple query which normally should take half a minute max. That's quite strange.

  • Issue is fixed, and queries are running fast again!

Login to post a comment