Supermetrics Support Forum

Data not loading for "Hour" dimension for Facebook ads connector

The data loads correctly when the dimesion is set as campaign name. Anyone else facing this issue?

  • Hi Adithya,


    Sorry to hear about the issue.


    Would you happen to have a screenshot displaying the problem? I'm not quite sure what the settings are for the graph that you've discovered the problem in, and that would be essential to know in order to reproduce. Thanks!


    Best,

    Heidi / Supermetrics

  • Hey Heidi,


    Here's the screenshot with campaign name as the dimension, all the data loads for this.

    image


    Here is the screenshot with hour as the dimension. There's no data showing for this:

    image


  • Hey,


    thanks for the screenshots. I'm afraid I could not replicate the issue on my report, but that is likely due to the fact that I'm not using the same metrics as you are, as the screenshots don't really tell what the selected metrics are (calculated fields?). Could you try dropping the metrics one-by-one to see if one of them is the reason to the error?


    Thanks,

    Heidi / Supermetrics

  • Hey,


    I think you might be right. It seems to be an issue with the table filters and not the calculated metrics.


    To set context, we've added filters based on campaign names to ensure the reports are filtered based on campaigns we want the metrics of and not all campaigns in the ad account.


    Would table filters be accessible in the pro version? As in, is this a limitation of the free tool?


  • Hi,


    thanks for checking that.


    Filters are not restricted from the free version, but something in the filters might cause the API to return a No Data message, if there's an incompatibility between filters and the metrics. Unfortunately in these cases there's nothing Supermetrics can do about it.


    Best,

    Heidi / Supermetrics

Login to post a comment