Supermetrics Support Forum

Scheduling Reports

Hi,


We are facing issues when we are trying to schedule reports. Some are not getting triggered on time. And sometimes they are not triggering at all.

  • Hi,

    Sorry to hear about the issues with triggers.


    I see your login has quite an amount of triggers set up, which could be the reason Sheets is no longer able to perform all of them. Also, be sure to set up hourly triggers only for the most important sheets.


    Currently Google Sheets is the one running scheduled refreshes on sheets and it sets limits on how long these processes can run per hour. Usually this time is around 6 minutes or so. As this runtime is shared between all your sheets that use triggers, with many files and queries refreshing at the same time, they are not always be completed in time and they are instead pushed to the next hour. This is the most common reason for delays with triggers.

    Normally Google provides more time to users with G Suite business account. If you are not using G Suite, upgrading to that can help.

    You should check if you have any files that use triggers which you do not need anymore. Triggers in those files might be delaying your scheduled refreshes. Also, please check if there are any such files in you recycle bin. Remove them permanently as triggers on those remain usually active regardless of their location. See all your triggers in Add-ons > Supermetrics > Schedule refresh & emailing > Manage triggers in all your files.

    To ease trigger runs, you may want to try and lighten the queries by using the setting "Combine new results with old" to only fetch the latest few days data, and combine it with the old. Set this up by doing the following steps:
    1.) Run the query so that you’ll see all the results that you wanted
    2.) Click on any of the cells containing results from that query
    3.) That query should be now open in the sidebar —> Click “modify”
    4.) Change the date range to last 7 days, or other shorter date range
    5.) Turn on “Combine new results with old” from Options dropdown in the sidebar
    6.) Make sure that you have any time dimension selected in your query (Date, Month, Year)
    7.) Click “Apply changes”


    If these measures do not help, please get back to us.

    Best regards,

    Heidi / Supermetrics team

Login to post a comment