Start a new topic

Email scheduling, "file not found" and not working in general

I'm trying to email something to myself as a test but it keeps giving me a "file not found":


Created: 2018-06-08Last refreshed: 2018-06-08Last status: Error: Email failed File not found: 1b6HQWBZp7JCW0lwtl1xUTwWTHv-oL8oL2tbUbkqKckg


Here are the settings I'm using (image attached). How do I fix this? I've tried to export in PDF and Excel worksheets.

Capture.JPG
(68.2 KB)
1 Comment

Hi Mateo,


There's a  couple of reasons this error can occur - check these to see if that is the issue:

Are you the owner of the file? You need to be the owner of it to set triggers.

By chance, has the Google Spreadsheet file itself been moved since you created the trigger? If so, you may need to recreate the trigger as it may remember the prior location and that is why it can't find it. Even if not, I would still advise to delete and recreate (if you have not tried this yet) just to rule out that it was saved incorrectly in the system.
 
Do you have Google for business account? If your Supemetrics license is linked to a non-business Google account, but the file is within your business Drive, it may automatically make the business account the file owner. This would result in the trigger not finding the file.

Is the file stored in a Team Drive location? The triggers do not work correctly from Team Drives as it doesn't have the right permissions to run the trigger. Moving the file to a private Drive location (the user with the license) should fix this.


-Thank you

Supermetrics Team

Login or Signup to post a comment