Failed to load: Unknown HTTP error


I've been encountering the error "Failed to load : Unknown HTTP error" since the November 22nd. 
I tried deleting then reinstalling the plugin for google sheets, but no success.

Could you please address this situation, 

Thank you

3 people have this problem
  • Hello!

    This is an issue we know about and our developers are currently investigating.

    Here's some additional steps that may help clear the error - depending on what is causing it - please test these and let us know if any of the help:

    1. Try clearing the cache and cookies of the browser. 
    2. Switching to incognito window might fix this issue.
    3. Sometimes, certain plugins and extensions interfere in the functionality of the Google Drive, disabling plugins and extension may help.
    4. Restart the device.
    5. You may also try using a different browser or operating system. 

    If nothing clears the issue, then it will need the pending fix. We will let you know once that is available.

    -Thank You
    Supermetrics Team

  • Hi Jessica,

    I tried all your suggestions, but I still get the same error everytime.

    Are you already working on this problem?

    When do you expect to deploy this fix?



  • Hi Luiz,

    Yes, as noted before we are actively working on the issue. Unfortunately, I have no timeline for when the fix will be ready right now. They are still investigating what is causing it.

    -Thank You

    Supermetrics Team

  • Hi!

    Just wanted to let you know that the developers have deployed a fix for this. Please reload the Google Sheet(s) with the issue and test again to see if this fixed the issue.

    -Thank You

    Supermetrics Team

  • Hi.

    No, still getting some errors, like

    "Account fetch error: Unknown HTTP error" on Bing Ads, Facebook Ads and Adwords

    "Segment fetch error: Unknown HTTP error" on Google Analytics

  • Hi Luiz,

    Can you then try this:

    Try to remove the Supermetrics app from the list of apps with account access in the Google account settings (, and then launch the sidebar again and grant the Supermetrics app the required Google permissions.

    If that also doesn't work then please submit a private ticket (or reply to an existing one for this if you already submitted) with the following information:

    *Which browser you are using

    *A screenshot of the extensions/plug-ins you are using for the browser

    *A screenshot of any additional Google Sheet Add-ons you have installed alongside Supermetrics

    -Thank You

    Supermetrics Team

  • We have some new information on this error - if you already resolved it, you can ignore this, but if you are still having Unknown HTTP errors, this may help.

    Google currently has a bug in their account management which is causing these issues. A temporary solution before Google releases a fix, is to use Supermetrics in an Incognito-mode window on your browser, and only log in to the tools with the single Google account that has your Supermetrics license.

    (Logging into multiple accounts in your browser at the same time is what can cause this issue. Also, using a separate Incognito window will not require you to log out from your other Google accounts.)

    If you'd like to help speeding up the fix from Googles side, please click on the star in this Google Bug report. More votes means it goes up in their urgency.

    We appreciate your help.

Login to post a comment