Start a new topic

Ad Network+Analytics Google Data Studio Connector not working


We haven't been able to use the Ad Network + Analytics connector for Google Data Studio for the past week.

When we select it as a source in the create a source page, we get this error :

"There was an error retrieving this Add-on's configuration"

When we click on Refresh Authorization, we keep getting the same error.

We've tried uninstalling and reinstalling the connector but the error is still there.

It's worth noting that the dashboards using the connector are still working properly (when the connector is installed, when we uninstall it the dashboard stops working, but the pleasant surprise is that when we reinstall it the settings are saved) 

Are we doing something wrong or is this a known bug ?

Thanks for the help !

(20.1 KB)
1 Comment

Hi Bou,

this issue should solve itself when you do these steps with all of the data sources that you're using in the data blending connector:


and on that page, if you see this, it means that your Google account belongs to multiple teams. Choose the one you know that has the paid license:


then click on "Add xxx xxx user account":


And when you have done these steps, your multi-datasource connector should work as well.

Best regards,

-Supermetrics Team

Login or Signup to post a comment