Database Refresh not returning all rows


When I create a query through Supermetrics Postgres connector it works fine, but scheduled refreshes (or doing Refresh All) does not return all the rows.

Do you have any ideas why this might be or how I can fix it?


1 person has this problem
  • Same here, first time on creation it returns all the rows. Next "refresh" manual or automatic only returns first 50 rows

    The column Max_rows in Supermetrics query is empty, and if I add a value by hand it gives me an error

    Please solve that problem. Thank you!

  • @Gonzalo - I found the Postgres connector buggy in general. Most days the schedule refreshes would fail with the error 'No connection details - please log out and log back in'.

    I have switched to using the Sql Server connector and this has worked with no issues. I know this isn't an option for everyone, but if you have a sql server / mysql alternative you might have more luck.

  • @Charlotte Thanks for your reply but I can't use the SQL server connector with a postgresql, right? I'm not an IT guy so that's why I am asking..

    Unfortunately I dont have the SQL / MYSQL alternative... Please Supermetric fix that!


Login to post a comment