Supermetrics Support Forum

Excel Integration

I'm using Excel 2016, but when I try and install Supermetrics it says I need to use an updated version of Excel, saying 2016 or newer. Has anyone else seen this? 


image


  • We had to upgrade to Office 365 (which is really Office 2019) in order to get the Add-in to "install" in Microsoft Excel.

  • Thanks 

  • Hey all,


    this is correct, Supermetrics for Excel requires Office 365 / Excel 2016, and to be precise it needs to be a "Click-to-run" installation, not MSI. 

    This is because the features that are needed for our product to work, are only supported by Excel API 1.6. This in turn only exists in Excel 2016 and newer.


    Best,

    Heidi / Supermetrics team

Login to post a comment

Didn't find what you were looking for?

Start a new topic