Supermetrics Support Forum

Sort by value, rather than alphabetically

My query is set to return Date and Hour.


Sorting is set to sort Date (Ascending) and then Hour (Ascending) as the secondary sort.


The problem is that it sorts the hours alphabetically rather than by value. 


Instead of 0,1,2,3...


it sorts


0,1,10,11,12...


How can I fix this? I've tried setting the number format in Google Sheets to "00" (which forces a leading zero onto one-digit numbers) on this column but that doesn't help. Every time this query updates, I have to manually sort the table.

  • Hi William,

    Thanks for reaching out.


    You're right, this functionality is not optimal. After you've formatted the cells to contain a leading zero, please try adding DISABLE_DIMENSION_AUTOFORMAT in the Advanced settings field of the Options section of this query (or in SupermetricsQueries sheet, Special settings column). That should disable any cell formatting as the query runs. 


    Let us know if this worked. Thanks!


    Best regards,

    Heidi / Supermetrics

Login to post a comment