Start a new topic

Script Error Issue

I got the following error when trying to run a new data pull:


Query failed: ScriptError. Try using Google Sheets logged in with just one Google account. There's a Google bug causing problems when logged into Sheets with multiple accounts.

 

I don't have multiple accounts open.


Hi Ondrej,

Just to rule out that it is that bug for certain, can you use the workaround given in this article for it?:

Authentication-, HTTP- or Script errors


If it does not work, let us know so we can then investigate other possible reasons.



-Thank you

Supermetrics team


I found this answer before so I did, I logged in with Incognito-Mode window, deleted cache, cookies, logged out, all options. Nothing helped. 


Thanks

Hi Ondrej,


I checked the logs but there's so many errors about the AdWords timeout problem (which you asked about in a different post), it's hard to tell if that is the reason for this or not. If you can clarify what query/data source this is happening on, I can filter the logs better to see what the issue may be.


Also for the future, please tell us anything you tried already in your issue report so we don't waste time repeating instructions you did and can jump ahead to the next part of troubleshooting.


-Thank you

Supermetrics Team


Hi Jessica, 


thanks for answer. I think it is already solved. My email is managing more than 1 Adwords MCC and I was not able to change the data source from one to another, Supermetrics just did not let me, always automatically connecting Adwords MCC number 1. 


I tried to delete cache, logged out, anynomous windows and all the tricks. In the end I somehow managed to change it. My problem now - and I also opened another ticket for it, so it can cancelled please, if I am running around 670 accounts, but only 2 or 3 columns of data, it gets frozen at 95% and won´t finish the query. But still looks like the data are updated and pulled out correctly. Should I be worried about the last 5%? 


Thank you

Hi Ondrej,


The tool updates the sheet in batches, so it's possible that the last 5% (or whatever the last chunk was) could be cut off. I've also seen cases though where the UI progress bar was stuck, but that the full data set was still populated (so not a problem with the update process, it kept running, but a UI glitch). The missing part would be the most recent data in the set, so hopefully you can cross-check if new items are absent or out-dated in what is returned to see if it's leaving parts out or not.


-Thank you

Supermetrics Team

Login or Signup to post a comment